summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a57f33f3834
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Akhil Jalagam <akhiljalagams@gmail.com>
+
+_pkgname=ondir
+pkgname=$_pkgname-git
+pkgver=r13.55279f0
+pkgrel=1
+pkgdesc="a small program to automate tasks specific to certain directories"
+arch=('i686' 'x86_64')
+url="https://github.com/alecthomas/ondir"
+license=('GPL2')
+makedepends=('git')
+depends=('glibc')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git://github.com/alecthomas/ondir.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make CFLAGS="$CFLAGS "'-DVERSION=\"$(VERSION)\" -DGLOBAL_CONF=\"$(CONF)\"' LDFLAGS="$LDFLAGS"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}