summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3dc143b13f4c..a086730d118c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,32 @@
# Contributor: jwwolf <jwwolf+arch@gmail.com>
pkgname=onioncat
-pkgver=0.3.0a
+pkgver=4.11.0
pkgrel=1
pkgdesc='OnionCat is a VPN-adapter, which uses Tor or I2P as its transport.'
arch=('i686' 'x86_64')
url='https://www.onioncat.org/'
license=('GPL3')
depends=('tor' 'net-tools')
-source=("https://www.cypherpunk.at/ocat/download/Source/current/${pkgname}-${pkgver}.tar.gz"{,.asc})
+#source=("https://www.cypherpunk.at/ocat/download/Source/current/${pkgname}-${pkgver}.tar.gz"{,.asc,.sha256,.sig})
+source=("https://github.com/rahra/onioncat/archive/refs/tags/v${pkgver}.tar.gz")
validpgpkeys=('98678E06063007E4A1F0B9C59BD601668E24F29D') # Bernhard R. Fischer (Eagle) <bf@abenteuerland.at>
-sha512sums=('3cf2ed5cbb021ffc49eb1ae4fe727a4964b1d4d3966f841bcf225e9c6415eee8b95360bab521ea7f6df7c4c27615017253d1ee6092d8f2ffaf45397dca2b7e8d'
- 'SKIP')
+#sha512sums=('b76da22051907e99f9a6ae6e089d5eb83502b6e3deb096ef00e4d2ed02da1c09b0aba1ad00c85e45622f92c94ba866930840b51b5859d775229606f40b463c59'
+# 'SKIP'
+# 'SKIP'
+# 'SKIP')
+sha512sums=('5dc6538f343749530cbd2f29bdd6ba6bc1e921a4fae6f5c783dd2bc1d045ce304639acc5cea6c1946b7c938ce58b732c01ae1a00998f5438a414b4c623dfd0bf')
+
build() {
cd "${pkgname}-${pkgver}"
- ./configure --prefix=/usr
+ ./autogen.sh
+ ./configure --prefix=/usr --localstatedir=/var/lib --runstatedir=/run --sysconfdir=/etc
make
}
package() {
cd "${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir/" install
+# make DESTDIR="$pkgdir" prefix="$pkgdir" install
+ make prefix="$pkgdir/usr" exec_prefix="$pkgdir/usr" localstatedir="$pkgdir/var/lib" install
}