summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c280cfcbcde9..d85185d2bafc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Michael J. Pento <mjpento at verizon dot net>
pkgname=onioncircuits
-pkgver=0.7
+pkgver=0.8
pkgrel=1
pkgdesc="GTK application to display Tor circuits and streams"
arch=('any')
@@ -10,22 +10,15 @@ url="https://gitlab.tails.boum.org/tails/onioncircuits"
license=('GPL3')
depends=('tor' 'hicolor-icon-theme' 'python>=3.4.2' 'python-gobject>=3.14.0' 'python-stem>=1.2.2' 'gobject-introspection' 'python-pycountry')
makedepends=('git' 'python-setuptools' 'python-distutils-extra')
-_commit=6efeff2e7cdbfbab7d73ea5825a64c002fa8e3b9 # tags/0.7^0
-source=("git+https://gitlab.tails.boum.org/tails/onioncircuits.git#commit=${_commit}"
- "setuptools_fix.patch")
-sha256sums=('SKIP'
- '6f2bab5e0337d0c62eb261b1a907e614f54e096b217e3c1e412d2a8086818f3d')
+_commit=ca2cfc399ca72446258c85300ad0ff975c5e213c # tags/0.8^0
+source=("git+https://gitlab.tails.boum.org/tails/onioncircuits.git#commit=${_commit}")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
git describe --tags | sed 's/-/+/g'
}
-prepare() {
- cd "${srcdir}/${pkgname}"
- patch -Np1 -i "${srcdir}/setuptools_fix.patch"
-}
-
build() {
cd "${srcdir}/${pkgname}"
python setup.py build