summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61555007ad6d..a2890bdf349e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Simon Hanna <thelinuxguy on freenode>
pkgname=onionshare
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc="Lets you securely and anonymously share a file of any size with someone"
url="https://github.com/micahflee/onionshare"
@@ -13,11 +13,12 @@ optdepends=(
'python-pyqt5: to run onionshare-gui'
'obfs4proxy: for tor bridge support'
)
+# if you want nautilus integration you need to remove the nautilus patch
source=(
https://github.com/micahflee/onionshare/archive/v$pkgver.tar.gz
nautilus-python.patch
)
-sha512sums=('f410db0866a10d57cbc227a3539f92b3e4fe6b8fdb459abefc315ff3e342aad6876ab963e50ce2c74c8213d07291b9a950a0f61b9cf43767e9befd5f64de01ea'
+sha512sums=('910928cf6e3672a8e59e452da1c5297b18f98854dbde836c02ef3458c33339f77cf16a0c5f2559ff364801a0e5ca2091bbb242aea8f6eaf00b0e8cbb6f261956'
'6cc3b3d178bea9cd9fecaf735e82ad7ff7161ad4396086881d7e45a9a70bd55c1074ec65c6359a64417a42493f305caf7ba89e1c40c9a9def03dd1d11cb7efb7')
@@ -25,10 +26,6 @@ prepare() {
cd "$srcdir/onionshare-$pkgver"
patch -i "${srcdir}/nautilus-python.patch"
}
-#build() {
-# cd "$srcdir/onionshare-$pkgver"
-# python setup.py build
-#}
check() {
cd "$srcdir/onionshare-$pkgver"