summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 16 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0de8b5dffd2..edd03d8a2d01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Simon Hanna <thelinuxguy on freenode>
+# Maintainer: Ye Shu <shuye02@outlook.com>
+
pkgname=onionshare
-pkgver=1.3.1
+pkgver=2.0
pkgrel=1
pkgdesc="Lets you securely and anonymously share a file of any size with someone"
url="https://github.com/micahflee/onionshare"
@@ -8,35 +9,26 @@ arch=('any')
license=('GPL3')
makedepends=('python-setuptools')
checkdepends=('python-pytest')
-depends=('stem' 'python-flask' 'tor')
+depends=('stem' 'python-flask' 'tor' 'python-pycryptodome' 'python-pysocks')
optdepends=(
- 'python-pyqt5: to run onionshare-gui'
- 'obfs4proxy: for tor bridge support'
- )
-# if you want nautilus integration you need to remove the nautilus patch
-source=(
- https://github.com/micahflee/onionshare/archive/v$pkgver.tar.gz
- nautilus-python.patch
- )
-sha512sums=('b0c2e2660900e270248781aa355c0f09163fc668aa48ee628a652acfd42fdc19079f583088545c94ee3fd928300cdbf683096ef1f6d334abdaac763bcb5708b2'
- 'd884248099f22ba72e99d40bce49d262ef2a481cc29af1d8b726c5d39eba2f6f21987317d44fea1eb46f136249da008523e6e6ae7d3f6be551966d5bfdd72552')
+ 'python-pyqt5: to run onionshare-gui'
+ 'python-nautilus: to enable Nautilus right-click extension'
+ 'obfs4proxy: for tor bridge support'
+)
-
-prepare() {
- cd "$srcdir/onionshare-$pkgver"
- patch -i "${srcdir}/nautilus-python.patch"
-}
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/micahflee/onionshare/archive/v$pkgver.tar.gz"
+)
+sha512sums=('1c3dbe90b52b1147f5dbe686453e518100fe7d71428a14231451c3e4a6f2aa8b4d1e5ea64cbb753ce2d7c3789f1479b9a715d2a68288dcf33e50070fb693520d')
check() {
cd "$srcdir/onionshare-$pkgver"
- pytest test/
+ pytest tests/
}
package() {
- cd "$srcdir/onionshare-$pkgver"
+ cd "$srcdir/onionshare-$pkgver" || return $?
python setup.py install --root="$pkgdir/" --optimize=1
- install -D -m 644 install/onionshare.desktop "${pkgdir}/usr/share/applications/onionshare.desktop"
- install -D -m 644 install/onionshare80.xpm "${pkgdir}/usr/share/pixmaps/onionshare80.xpm"
+ install -Dm644 install/onionshare.desktop "${pkgdir}/usr/share/applications/onionshare.desktop"
+ install -Dm644 install/onionshare80.xpm "${pkgdir}/usr/share/pixmaps/onionshare80.xpm"
}
-
-# vim:set ts=2 sw=2 et: