summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4b87b055d6a..eb8c2e80d62f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=onnxruntime
pkgname=onnxruntime-git
-pkgver=0
+pkgver=orttraining_rc2.r2552.g5f30be3e92
pkgrel=1
pkgdesc="cross-platform inference and training machine-learning accelerator."
arch=('x86_64')
@@ -26,6 +26,11 @@ prepare() {
git submodule update --init --recursive
}
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "$_pkgname"
# ./build.sh --config RelWithDebInfo --build_shared_lib --parallel