summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f7d1cfb3ae4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=onyx-git
+pkgver=0.4.2+37+g84feff8
+pkgrel=1
+pkgdesc='Decentralized messaging application based on PSS (git)'
+arch=(any)
+url='https://mainframe.com'
+license=(MIT)
+depends=(yarn)
+makedepends=(libicns)
+conflicts=(onyx onyx-bin)
+options=(!strip)
+source=(git+https://github.com/MainframeHQ/onyx.git)
+sha512sums=(SKIP)
+
+pkgver() {
+ cd $srcdir/onyx
+ git describe --tags | sed 's/v//;s/-/+/g'
+}
+
+build() {
+ cd $srcdir/onyx
+ yarn
+ yarn build:binaries
+ yarn dist
+}
+
+package() {
+ cd $srcdir/onyx
+ install -Dm 755 dist/Mainframe\ Alpha.AppImage $pkgdir/usr/bin/onyx
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/onyx/LICENSE
+}