summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2bd42a55178..d74fdc61c630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,11 @@
pkgname=openblas-lapack
_PkgName=OpenBLAS
_pkgname=openblas
-pkgver=0.3.22
+pkgver=0.3.23
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
_lapackver=3.11.0
_blasver=3.11.0
-pkgrel=2
+pkgrel=1
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('x86_64')
url="http://www.openblas.net/"
@@ -21,7 +21,7 @@ provides=('openblas' "blas=${_blasver}" "lapack=${_lapackver}" "cblas=${_blasver
conflicts=('openblas' 'blas' 'lapack' 'cblas' 'lapacke')
options=(!emptydirs)
source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/OpenBLAS/releases/download/v${pkgver}/OpenBLAS-$pkgver.tar.gz)
-sha256sums=('7fa9685926ba4f27cfe513adbf9af64d6b6b63f9dcabb37baefad6a65ff347a7')
+sha256sums=('5d9491d07168a5d00116cdc068a40022c3455bf9293c7cb86a65b1054d7e5114')
# Add the following line to the _config variable if you want to set the number of make jobs
# MAKE_NB_JOBS=2 \
@@ -35,6 +35,12 @@ build(){
make ${_config} shared
}
+check() {
+ cd "${_PkgName}-${pkgver}"
+ unset MAKEFLAGS
+ make ${_config} tests
+}
+
package(){
cd "${_PkgName}-${pkgver}"