summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e5d53c86672..c5a3f48a9a40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgver=0.3.19
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
_lapackver=3.9.0
_blasver=3.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('x86_64')
url="http://www.openblas.net/"
@@ -20,8 +20,10 @@ makedepends=('perl' 'gcc-fortran')
provides=('openblas' "blas=${_blasver}" "lapack=${_lapackver}" "cblas=${_blasver}" "lapacke=${_lapackver}")
conflicts=('openblas' 'blas' 'lapack' 'cblas' 'lapacke')
options=(!emptydirs)
-source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz)
-sha256sums=('947f51bfe50c2a0749304fbe373e00e7637600b0a47b78a51382aeb30ca08562')
+source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/xianyi/OpenBLAS/pull/3504.patch)
+sha256sums=('947f51bfe50c2a0749304fbe373e00e7637600b0a47b78a51382aeb30ca08562'
+ '52a0ce2e8c7e3904cd1f2e65ab877d9370a6fcd23a1cd35e2e6a7ffa9fb4434c')
# Add the following line to the _config variable if you want to set the number of make jobs
# MAKE_NB_JOBS=2 \
@@ -30,6 +32,11 @@ _config="FC=gfortran USE_OPENMP=1 USE_THREAD=1 \
NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1 \
MAJOR_VERSION=${_lapackver:0:1} NO_STATIC=1"
+prepare(){
+ cd "${_PkgName}-${pkgver}"
+ patch -p1 -i ../3504.patch
+}
+
build(){
cd "${srcdir}/${_PkgName}-${pkgver}"