summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c211760f7c7..45cd13f38882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: MichaƂ Walenciak <kicer86@gmail.com>
pkgname=openblok
pkgver=0.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="A customizable, cross platform, open-source falling block game, packed with a bunch of features."
arch=('i686' 'x86_64')
url="https://github.com/mmatyas/openblok"
@@ -17,13 +17,15 @@ backup=()
options=()
install=
changelog=
-source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver)
+source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver 0001-Fixed-AppImage-data-path.patch)
noextract=()
-md5sums=('0c82fadc6573e4fa0fe84171d169d978')
+md5sums=('0c82fadc6573e4fa0fe84171d169d978'
+ '47cb3991c7997149f9229230969342ee')
build()
{
cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/0001-Fixed-AppImage-data-path.patch"
mkdir -p build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DEXEDIR=/usr/bin