summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7afe8ace4f2..826d56197961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=opencamlib-git
-pkgver=2018.08.25.gf31b0a6
+pkgver=2019.07.4.g983a416
pkgrel=1
pkgdesc="Multi-Purpose CNC Toolpath Library"
arch=('i686' 'x86_64')
url="https://github.com/aewallin/opencamlib"
license=('LGPL')
makedepends=('boost' 'cmake' 'doxygen')
-depends=('python2' 'boost')
+depends=('python' 'boost')
provides=('opencamlib')
conflicts=('opencamlib')
source=("git+https://github.com/aewallin/opencamlib.git")
@@ -22,7 +22,7 @@ pkgver() {
build() {
mkdir "$srcdir/opencamlib/build"
cd "$srcdir/opencamlib/build"
- cmake -DCMAKE_INSTALL_PREFIX=/usr ../src
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DUSE_PY_3="ON" -DBUILD_PY_LIB="ON" ../src
make
}