summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73b1d2cd4c80..5099b2f50cbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: Uffe Jakobsen <microtop@starion.dk>
#
pkgname=opencbm-git
-pkgver=r1252.9b57b1f
+pkgver=r1436.7134118b
pkgrel=1
epoch=
pkgdesc="OpenCBM allows access to Commodore (C64) storage devices VIC 1540, 1541, 1570, 1571, or even 1581 floppy drive"
@@ -13,14 +13,14 @@ arch=('i686' 'x86_64')
url="http://sourceforge.net/projects/opencbm/"
license=('GPL2')
groups=()
-depends=('ncurses' 'libusb' 'libusb-compat')
-makedepends=('cc65')
+depends=('libusb')
+makedepends=('git' 'cc65')
checkdepends=()
-optdepends=()
-provides=()
+optdepends=('ncurses: enable interactive mode for cbmlinetester')
+provides=('opencbm')
conflicts=()
replaces=()
-backup=()
+backup=('etc/opencbm.conf')
options=()
install=
changelog=
@@ -32,6 +32,9 @@ md5sums=('SKIP')
build_kernel_module=
+#
+#
+#
pkgver()
{
@@ -46,8 +49,6 @@ prepare()
sed -i '\!#include <asm/uaccess.h>!s!.*!&\n#include <linux/uaccess.h>\n#include <linux/sched/signal.h>!' opencbm/sys/linux/cbm_module.c
# kernel module: Makefile is needed later
sed -i '\!-rm -f Makefile!d' opencbm/sys/linux/LINUX/Makefile
- # HACK: testlines.1 does not exist
- touch opencbm/sample/testlines/testlines.1
}
build()
@@ -76,6 +77,13 @@ package()
make -f LINUX/Makefile PREFIX="/usr" MANDIR="/usr/share/man/man1" INFODIR="/usr/share/info" DESTDIR="${pkgdir}/" install install-plugin-xum1541 install-plugin-xu1541
mv "${pkgdir}/etc/opencbm.conf" "${pkgdir}/etc/opencbm.conf.sample"
+ # Don't overwrite ld.so.conf
+ rm -f ${pkgdir}/etc/ld.so.conf
+
+ # Remove scary warning from /etc/opencbm.conf and don't install both /etc/opencbm.conf.d/ and opencbm_plugin_helper_tools at all
+ ##sed -i "/^;.*/d" ${pkgdir}/etc/opencbm.conf
+ ##rm -rf ${pkgdir}/etc/opencbm.conf.d/
+ ##rm ${pkgdir}/usr/bin/opencbm_plugin_helper_tools
# kernel module: build (optional)
if test "${build_kernel_module}" != ""; then