summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3919c311a93..99213a0b0549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,33 @@
-# ---------------------------------------------------------------
-# Maintainer: Romain Bazile <gromain.baz@gmail.com>
-# ---------------------------------------------------------------
+# Maintainer: cybuzuma <cybuzuma at vnxs dot de>
+# Contributor: Romain Bazile <gromain.baz@gmail.com>
pkgname=opencpn-git
-pkgver=5.2.0.r217.gffdf4cb6e
+pkgver=5.6.0.r1162.gef059cb76
pkgrel=1
pkgdesc="Open Source Chart Plotting / Marine Navigation - Git version"
arch=('x86_64' 'aarch64')
license=("GPL2")
-depends=('wxgtk3' 'gpsd' 'portaudio' 'tinyxml' 'hicolor-icon-theme' 'webkit2gtk' 'lsb-release')
-makedepends=('cmake' 'git')
+depends=('wxgtk3' 'portaudio' 'tinyxml' 'libsndfile' 'libarchive' 'libexif' 'glu' 'webkit2gtk' 'wxsvg')
+optdepends=('gpsd: GPS position support')
+makedepends=('cmake' 'git' 'lsb-release')
conflicts=('opencpn')
provides=('opencpn')
url="http://opencpn.org"
-install=opencpn.install
source=("$pkgname::git+https://github.com/OpenCPN/OpenCPN.git")
sha1sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --long --tags | sed -r 's/^[vV]//;s/\_/\./;s/([^-]*-g)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd $pkgname
+ git describe --long --tags | sed -r 's/^Release.//;s/\_/\./;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
cd $pkgname
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
- -DOCPN_BUNDLE_GSHHS=CRUDE -DOCPN_BUNDLE_TCDATA=ON -DOCPN_BUNDLE_DOCS=ON \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
- -DOCPN_FORCE_GTK3=ON ../
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DOCPN_BUILD_TEST=OFF -DOCPN_VERBOSE=OFF -DOCPN_USE_EXTERN_CURL=ON ..
make
}