summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb4323ff0e4a..46dc5d2a3323 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=opencpn-plugin-climatology
pkgver=1.4
-pkgrel=2
+pkgrel=3
pkgdesc="Climatology plugin for OpenCPN"
arch=('x86_64')
license=("GPL3")
@@ -15,13 +15,17 @@ source=("https://github.com/seandepagnier/climatology_pi/archive/v${pkgver}.tar.
sha1sums=('5fa481df6bfd073d80d66297bc97e814207b98c2'
'5829a5c95fda9fa4a6963dbfffacf23f60d061e5')
+prepare(){
+ git submodule update
+}
+
build() {
cd ${srcdir}
- cp data/* climatology_pi-${pkgver}/data
+ cp data/* climatology_pi-${pkgver}/data/
cd "climatology_pi-${pkgver}"
mkdir -p build
cd build
- cmake -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 ..
make
}