summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d164916e5fe9..18e56b030bb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=openfaas-cli
pkgdir="pkg-build"
pkgdesc="OpenFaaS CLI"
-pkgver=0.6.11
+pkgver=0.6.13
pkgrel=1
arch=('i686' 'x86_64' 'arm64')
url="https://github.com/openfaas/faas-cli"
@@ -11,15 +11,15 @@ license=('mit')
makedepends=('go' 'dep')
source=("https://github.com/openfaas/faas-cli/archive/$pkgver.tar.gz")
-sha256sums=('07fbf1886fc50411e0e1f69c5f93957c9f99a2e75a023f82931ee978ba3fa2c7')
+sha256sums=('0ef135535fcf561a900736f1bf7c04e3ec79196850123ed489dc08fd6e838ca2')
build() {
GOPATH=$startdir
- sudo rm -rf $GOPATH/pkg
+ rm -rf $GOPATH/pkg || true
cd "$srcdir/faas-cli-$pkgver"
dep ensure
- CGO_ENABLED=0 GOOS=linux go build --ldflags "-s -w -X github.com/openfaas/faas-cli/version.Version=0.6.10" -a -installsuffix cgo -o faas-cli
+ CGO_ENABLED=0 GOOS=linux go build --ldflags "-s -w -X github.com/openfaas/faas-cli/version.Version=$pkgver" -a -installsuffix cgo -o faas-cli
}
package() {