summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 6 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c65dc1f8a27b..509f285f8398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=openfx-arena-git
name=openfx-arena
pkgver=2.3.3
-pkgrel=4
+pkgrel=5
arch=("i686" "x86_64")
pkgdesc="A set of Readers/Writers plugins written using the OpenFX standard"
url="https://github.com/MrKepzie/openfx-io"
@@ -13,29 +13,18 @@ depends=("seexpr1" "openimageio" "ffmpeg")
#depends=("opencolorio" "openexr" "openimageio" "ffmpeg" "boost-libs")
makedepends=("git" "expat" "boost")
optdepends=("openfx-gmic-bin" "natron-plugins")
-source=("$pkgname::git+https://github.com/MrKepzie/openfx-arena.git#commit=6c9adf4026446cb688fc9878c768cac103582603"
- 'git+https://github.com/devernay/openfx.git'
- 'git+https://github.com/MrKepzie/SequenceParsing'
- 'git+https://github.com/devernay/openfx-supportext.git'
- 'git+https://github.com/MrKepzie/tinydir')
+source=("openfx-arena::git+https://github.com/MrKepzie/openfx-arena.git#commit=6c9adf4026446cb688fc9878c768cac103582603"
+)
sha512sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+)
_bits=32 ; [[ "$CARCH" = 'x86_64' ]] && _bits=64
prepare() {
cd "$srcdir/$name"
- git config submodule.openfx.url $srcdir/openfx
- git config submodule.IOSupport/SequenceParsing.url $srcdir/SequenceParsing
- git config submodule.SupportExt.url $srcdir/openfx-supportext
- git submodule update
- cd IOSupport/SequenceParsing
- git config submodule.tinydir.url $srcdir/tinydir
- git submodule update
+ git submodule update --init --recursive
+
}
build() {