summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f21932ad78c..7fca497b5d2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
pkgname=openfx-gmic-git
-pkgver=Natron.2.4.3.r0.g100d960
+pkgver=2.4.4.r9.g292ac55
pkgrel=1
arch=('x86_64')
pkgdesc="OpenFX wrapper for the G'MIC framework"
url="https://github.com/NatronGitHub/openfx-gmic"
-license=('custom:CeCILL-C' 'custom:CeCILLv2')
+license=('CECILL-C OR CECILL-2.0')
depends=('fftw' 'libgl' 'libpng')
makedepends=('git' 'openmp')
+
_pkgname=${pkgname%-git}
_url=${url%/${_pkgname}}
@@ -22,14 +23,14 @@ sha512sums=('SKIP'
pkgver() {
cd ${_pkgname}
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^Natron.//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd ${_pkgname}
git submodule init
git config submodule.openfx.url ${srcdir}/openfx
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build() {