summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0979a0b80afa..16504a4bc22c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,28 @@
# Contributor: Hugo Courtial <hugo [at] courtial [not colon] me>
# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
+_openfx_misc_commit=41119a6
+_openfx_commit=c70de42
+_openfx_supportext_commit=9fa7ca1
+
pkgname=openfx-misc
-pkgver=2.3.14
+pkgver=2.3.15_pre4
pkgrel=1
-arch=("i686" "x86_64")
+arch=("i686" "pentium4" "x86_64")
pkgdesc="Miscellaneous OpenFX plugins"
url="https://github.com/NatronGitHub/openfx-misc"
license=("GPL")
-makedepends=("git" "openmp")
+makedepends=("openmp")
depends=("libgl")
-optdepends=("natron-plugins")
-source=("$pkgname::git+https://github.com/NatronGitHub/openfx-misc#tag=Natron-$pkgver"
- "git+https://github.com/NatronGitHub/openfx"
- "git+https://github.com/NatronGitHub/openfx-supportext")
+source=("openfx-misc_$_openfx_misc_commit.tar.gz::https://github.com/NatronGitHub/openfx-misc/tarball/$_openfx_misc_commit"
+ "openfx_$_openfx_commit.tar.gz::https://github.com/NatronGitHub/openfx/tarball/$_openfx_commit"
+ "openfx-supportext_$_openfx_supportext_commit.tar.gz::https://github.com/NatronGitHub/openfx-supportext/tarball/$_openfx_supportext_commit")
sha512sums=('SKIP'
'SKIP'
'SKIP')
+_pkgname="NatronGitHub-$pkgname-$_openfx_misc_commit"
+
# Checks whether the environment is 32-bit or 64-bit
if [ $CARCH == 'x86_64' ]
then
@@ -28,14 +33,14 @@ else
fi
prepare() {
- cd "$srcdir/$pkgname"
- git config submodule.openfx.url $srcdir/openfx
- git config submodule.SupportExt.url $srcdir/openfx-supportext
- git submodule update
+ tar -xzf "$srcdir/openfx_$_openfx_commit.tar.gz" --strip 1 \
+ -C "$srcdir/$_pkgname/openfx/"
+ tar -xzf "$srcdir/openfx-supportext_$_openfx_supportext_commit.tar.gz" --strip 1 \
+ -C "$srcdir/$_pkgname/SupportExt/"
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgname"
make CONFIG=release \
CXXFLAGS_ADD=-fopenmp \
LDFLAGS_ADD=-fopenmp \
@@ -43,7 +48,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgname"
mkdir -p "$pkgdir/usr/OFX/Plugins"
make install PLUGINPATH=$pkgdir/usr/OFX/Plugins \
CONFIG=release \