summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7e1e1f3b89e..0979a0b80afa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=openfx-misc
-pkgver=2.3.13
+pkgver=2.3.14
pkgrel=1
-arch=("x86_64")
+arch=("i686" "x86_64")
pkgdesc="Miscellaneous OpenFX plugins"
url="https://github.com/NatronGitHub/openfx-misc"
license=("GPL")
-makedepends=("git")
+makedepends=("git" "openmp")
depends=("libgl")
optdepends=("natron-plugins")
source=("$pkgname::git+https://github.com/NatronGitHub/openfx-misc#tag=Natron-$pkgver"
@@ -19,6 +19,14 @@ sha512sums=('SKIP'
'SKIP'
'SKIP')
+# Checks whether the environment is 32-bit or 64-bit
+if [ $CARCH == 'x86_64' ]
+then
+ _BITS=64
+else
+ _BITS=32
+fi
+
prepare() {
cd "$srcdir/$pkgname"
git config submodule.openfx.url $srcdir/openfx
@@ -29,7 +37,9 @@ prepare() {
build() {
cd "$srcdir/$pkgname"
make CONFIG=release \
- BITS=64
+ CXXFLAGS_ADD=-fopenmp \
+ LDFLAGS_ADD=-fopenmp \
+ BITS=$_BITS
}
package() {
@@ -37,5 +47,5 @@ package() {
mkdir -p "$pkgdir/usr/OFX/Plugins"
make install PLUGINPATH=$pkgdir/usr/OFX/Plugins \
CONFIG=release \
- BITS=64
+ BITS=$_BITS
}