summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf4eef06056e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Hugo Courtial <hugo [at] courtial [not colon] me>
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+
+pkgname=openfx-misc-git
+pkgver=2.3.3
+pkgrel=3
+arch=("i686" "x86_64")
+pkgdesc="A set of Readers/Writers plugins written using the OpenFX standard"
+url="https://github.com/MrKepzie/openfx-io"
+license=("GPL2")
+depends=("seexpr1" "openimageio" "ffmpeg")
+#depends=("opencolorio" "openexr" "openimageio" "ffmpeg" "boost-libs")
+makedepends=("git" "expat" "boost")
+optdepends=("openfx-gmic-bin" "natron-plugins")
+source=("$pkgname::git+https://github.com/MrKepzie/openfx-misc.git#commit=5b01ce1fff57fb0af801031ff9c0d3d3f2b85beb"
+ 'git+https://github.com/devernay/openfx.git'
+ 'git+https://github.com/MrKepzie/SequenceParsing'
+ 'git+https://github.com/devernay/openfx-supportext.git'
+ 'git+https://github.com/MrKepzie/tinydir')
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+_bits=32 ; [[ "$CARCH" = 'x86_64' ]] && _bits=64
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git config submodule.openfx.url $srcdir/openfx
+ git config submodule.IOSupport/SequenceParsing.url $srcdir/SequenceParsing
+ git config submodule.SupportExt.url $srcdir/openfx-supportext
+ git submodule update
+
+ cd IOSupport/SequenceParsing
+ git config submodule.tinydir.url $srcdir/tinydir
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make CONFIG=release BITS=$_bits
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p "$pkgdir/usr/OFX/Plugins"
+ make install PLUGINPATH=$pkgdir/usr/OFX/Plugins CONFIG=release BITS=$_bits
+} \ No newline at end of file