summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4abc0be0b465..e91946ff7ffa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: drakkan <nicola.murino@gmail.com>
-# Contributor: drakkan <nicola.murino@gmail.com>
+# Maintainer: drakkan <nicola.murino at gmail dot com>
+# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=openh264
-pkgver=1.6.0
+pkgver=1.7.0
pkgrel=1
pkgdesc='OpenH264 is a codec library which supports H.264 encoding and decoding'
license=('BSD')
@@ -11,12 +11,7 @@ url="http://www.openh264.org/"
depends=('gcc-libs')
makedepends=('nasm')
source=("https://github.com/cisco/openh264/archive/v${pkgver}.tar.gz")
-sha256sums=('65d307bf312543ad6e98ec02abb7c27d8fd2c9740fd069d7249844612674a2c7')
-
-prepare() {
- cd "openh264-$pkgver"
- sed -i 's/PREFIX=\/usr\/local/PREFIX=\/usr/g' Makefile
-}
+sha256sums=('9c07c38d7de00046c9c52b12c76a2af7648b70d05bd5460c8b67f6895738653f')
build() {
cd "openh264-$pkgver"
@@ -25,7 +20,7 @@ build() {
package() {
cd "openh264-$pkgver"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
install -Dm755 h264dec "$pkgdir"/usr/bin/h264dec
install -Dm755 h264enc "$pkgdir"/usr/bin/h264enc
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE