summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38d2f1bb420e..f44fe18462b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,24 +13,22 @@ license=('Apache')
depends=(intel-tbb python)
provides=("openimagedenoise=${pkgver%.r*}")
conflicts=(openimagedenoise)
-makedepends=(git makepkg-git-lfs-proto cmake 'ispc>=1.14' ninja)
+makedepends=(git cmake 'ispc>=1.14' ninja)
source=("${pkgname%-git}::git+https://github.com/OpenImageDenoise/oidn.git${_fragment}"
"git+https://github.com/OpenImageDenoise/mkl-dnn.git"
- "git-lfs+https://github.com/OpenImageDenoise/oidn-weights.git"
"git+https://github.com/NVIDIA/cutlass"
"git+https://github.com/ROCmSoftwarePlatform/composable_kernel"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'SKIP')
prepare() {
git -C "${srcdir}"/${pkgname%-git} config submodule.mkl-dnn.url "${srcdir}"/mkl-dnn
- git -C "${srcdir}"/${pkgname%-git} config submodule.weights.url "${srcdir}"/oidn-weights
git -C "${srcdir}"/${pkgname%-git} config submodule.cutlass.url "${srcdir}"/cutlass
git -C "${srcdir}"/${pkgname%-git} config submodule.external/composable_kernel.url "${srcdir}"/composable_kernel
+ sed 's|../oidn-weights.git|https://github.com/OpenImageDenoise/oidn-weights.git|' -i "${srcdir}"/${pkgname%-git}/.gitmodules
git -C "${srcdir}"/${pkgname%-git} -c protocol.file.allow=always submodule update --init --recursive # --remote
}