summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5ee5781aed7..f9962b318cb7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,17 +55,15 @@ build() {
-DOPENMC_USE_MPI=ON \
-DHDF5_PREFER_PARALLEL=ON \
-DCMAKE_INSTALL_PREFIX=/opt/openmc
- _ccores=`cat /proc/cpuinfo |grep CPU|wc -l`
- if [ "x$1" != "x" ]; then
- _ccores=$1
- fi
- make -j ${_ccores}
+ _ccores=$(nproc)
+ if [ -z "${_ccores}" ]; then
+ make
+ else
+ make -j ${_ccores}
+ fi
- # build python layer
- python \
- -m build \
- --wheel \
- --no-isolation ../
+ # build python layer
+ python -m build --wheel --no-isolation ../
}
package() {