summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0ef6c720c69..bc6451399459 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=openmodelica
pkgver=1.17.0
-pkgrel=2
+pkgrel=3
pkgdesc="Open-source Modelica-based modeling and simulation environment"
url="https://www.openmodelica.org"
_giturl="https://github.com/OpenModelica/OpenModelica.git"
@@ -8,7 +8,7 @@ license=('OSMC-PL')
arch=('x86_64')
depends=('java-environment' 'lapack' 'openscenegraph' 'omniorb' 'libcurl-gnutls'
'lpsolve' 'boost-libs' 'qt5-webkit' 'qt5-xmlpatterns' 'qt5-svg' 'qt5-tools'
- 'expat')
+ 'expat' 'antlr4-runtime')
makedepends=('gcc-fortran' 'cmake' 'git')
source=("${pkgname}::git+${_giturl}#tag=v${pkgver}")
sha256sums=('SKIP')
@@ -18,13 +18,15 @@ prepare() {
git remote set-url origin ${_giturl}
git submodule update --force --init --recursive
# OMCompiler: Dont try to install translations
- git cherry-pick 2a39a402d9604a1ce353b0a12574fed5d320be0e
+ git cherry-pick -n 2a39a402d9604a1ce353b0a12574fed5d320be0e
# Fix build with cmake >= 3.20
- git cherry-pick 4f3a50974f0f916efd716809699f18d47f1dbe34
+ git cherry-pick -n 4f3a50974f0f916efd716809699f18d47f1dbe34
}
build() {
cd "${pkgname}"
+ # See https://github.com/OpenModelica/OpenModelica/issues/7619
+ export CXXFLAGS=-std=c++14
autoreconf -fi
./configure --prefix=/usr
make