summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bdc6d53eee41..724cabf750ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=openmodelica
-pkgver=1.22.1
+pkgver=1.22.2
pkgrel=1
pkgdesc="Open-source Modelica-based modeling and simulation environment"
url="https://www.openmodelica.org"
@@ -7,7 +7,7 @@ _giturl="https://github.com/OpenModelica/OpenModelica.git"
license=('OSMC-PL')
arch=('x86_64')
depends=('java-environment' 'lapack' 'lapack-static' 'openscenegraph' 'omniorb' 'libcurl-gnutls'
- 'lpsolve' 'boost-libs' 'qt5-webkit' 'qt5-xmlpatterns' 'qt5-svg' 'qt5-tools'
+ 'lpsolve' 'boost-libs' 'qt5-webengine' 'qt5-xmlpatterns' 'qt5-svg' 'qt5-tools'
'expat' 'antlr4-runtime')
makedepends=('gcc-fortran' 'cmake' 'git' 'boost')
source=("${pkgname}::git+${_giturl}#tag=v${pkgver}")
@@ -21,14 +21,13 @@ prepare() {
build() {
cd "${pkgname}"
- autoreconf -fi
- ./configure --prefix=/usr --without-omc
- make
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DOM_USE_CCACHE=OFF -DOM_OMEDIT_ENABLE_QTWEBENGINE=ON -B build .
+ make -C build
}
package() {
cd "${pkgname}"
- make install DESTDIR=${pkgdir}
+ make install -C build DESTDIR=${pkgdir}
# Correct ownership of files, otherwise FMU export fails
chmod go+rx "${pkgdir}"/usr/share/omc/runtime/c/fmi/buildproject/config.*
}