summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b567499a82f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Tom < reztho at archlinux dot us >
+pkgname=openmsx
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="The MSX emulator that aims for perfection."
+arch=('i686' 'x86_64')
+url="http://openmsx.sourceforge.net"
+license=('custom')
+depends=('libxml2' 'sdl' 'sdl_image' 'sdl_ttf' 'tcl' 'libpng' 'zlib')
+optdepends=('python2' 'jack-audio-connection-kit' 'glew' 'libgl' 'catalyst-utils' 'nvidia-utils' 'nvidia-304xx-utils')
+install=${pkgname}.install
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Changing some default configurations...
+ sed -i 's@SYMLINK_FOR_BINARY:=true@SYMLINK_FOR_BINARY:=false@' build/custom.mk
+ sed -i 's@INSTALL_BASE:=/opt/openMSX@INSTALL_BASE:=/usr/share/openmsx@' build/custom.mk
+ echo 'INSTALL_DOC_DIR:=/usr/share/doc/openmsx' >> build/custom.mk
+ echo 'INSTALL_SHARE_DIR:=/usr/share/openmsx' >> build/custom.mk
+ echo 'INSTALL_BINARY_DIR:=/usr/bin' >> build/custom.mk
+
+ # Compiling
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # Licenses
+ mkdir -p "${pkgdir}/usr/share/licenses/openmsx"
+ ln -s /usr/share/licenses/common/GPL2/license.txt "${pkgdir}/usr/share/licenses/openmsx/openmsx.txt"
+ install -m 644 "${pkgdir}/usr/share/doc/openmsx/cbios.txt" "${pkgdir}/usr/share/licenses/openmsx/"
+}
+
+md5sums=('b6f9c92f3921d9022b89b727c99897f0')