summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a409a0561316
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Brenton Horne <brentonhorne77@gmail.com>
+
+pkgname=openra-wts-git
+pkgver=29131.git.f5aa2f1
+pkgrel=1
+pkgdesc="OpenRA built from latest git commit and with the experimental Tiberian Sun mod included."
+arch=('x86_64')
+url="https://www.openra.net"
+license=('GPL3')
+install=${pkgname}.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('git' 'unzip' 'mono-msbuild')
+conflicts=('openra' 'openra-bleed' 'openra-git')
+options=(!strip)
+source=("git+https://github.com/OpenRA/OpenRA.git"
+"https://raw.githubusercontent.com/wiki/OpenRA/OpenRA/Changelog.md")
+sha256sums=('SKIP'
+ '5d07623dc97c88b07435f54857093ca41073d96b93a4c8b5bf8fd0768835a8ff')
+
+pkgver() {
+ cd $srcdir/OpenRA
+ no=$(git rev-list --count HEAD)
+ hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
+ version="${no}.git.${hash}"
+ make version VERSION="${version}"
+}
+
+build() {
+ cd $srcdir/OpenRA
+ make all RUNTIME=mono DEBUG=false TARGETPLATFORM=unix-generic
+}
+
+package() {
+ cd $srcdir/OpenRA
+ mkdir -p $pkgdir/usr/lib/openra
+ make prefix=/usr DESTDIR="$pkgdir" install DEBUG=false RUNTIME=mono
+ make prefix=/usr DESTDIR="$pkgdir" install-linux-shortcuts DEBUG=false
+ make prefix=/usr DESTDIR="$pkgdir" install-linux-appdata DEBUG=false
+ cp -r mods/ts $pkgdir/usr/lib/openra/mods
+ cp $pkgdir/usr/bin/openra-ra $pkgdir/usr/bin/openra-ts
+ cp $pkgdir/usr/share/applications/openra-ra.desktop $pkgdir/usr/share/applications/openra-ts.desktop
+ sed -i -e "s|-ra|-ts|g" \
+ -e "s|=ra|=ts|g" \
+ -e "s|Red Alert|Tiberian Sun|g" $pkgdir/usr/bin/openra-ts
+ sed -i -e "s|-ra|-ts|g" \
+ -e "s|Red Alert|Tiberian Sun|g" $pkgdir/usr/share/applications/openra-ts.desktop
+}