summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b83823818f6a..99bf56ef2422 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,27 @@
+# Maintainer: Daichi Shinozaki <dseg@shield.jp>
# Contributor: Jean-Sébastien Ney <jeansebastien.ney@gmail.com>
# Contributor: James Cleveland <jc@blackflags.co.uk>
# Contributor: Eimantas Bunevičius <eimantaster@gmail.com>
-# Commit improvements: https://github.com/eimiss/aur-openresty
_cfgdir=/opt/openresty/nginx/conf
_tmpdir=/var/lib/openresty
pkgname=openresty
pkgver=1.9.7.3
-pkgrel=1
+pkgrel=2
pkgdesc="A Fast and Scalable Web Platform by Extending NGINX with Lua"
arch=('i686' 'x86_64')
url="http://openresty.org/"
license=('BSD')
depends=('perl>=5.6.1' 'readline' 'pcre' 'openssl')
-makedepends=('git')
install=
source=(http://openresty.org/download/$pkgname-$pkgver.tar.gz
service
openresty.logrotate
- 'git+https://github.com/openresty/stream-lua-nginx-module.git'
- 'git+https://github.com/openresty/stream-echo-nginx-module.git'
)
noextract=()
sha256sums=('3e4422576d11773a03264021ff7985cd2eeac3382b511ae3052e835210a9a69a'
'ec55ac7da98f5f5ec54d096c5f79b656edec0ebca835b6b9f1d20fb7be7119c5'
'613b0ed3fe4b5ee505ddb5122ee41604f464a5049be81c97601ee93970763a23'
- 'SKIP'
- 'SKIP')
-
+ )
backup=(${_cfgdir:1}/fastcgi.conf
${_cfgdir:1}/fastcgi_params
${_cfgdir:1}/koi-win
@@ -59,8 +54,6 @@ build() {
--with-http_v2_module \
--with-stream \
--with-stream_ssl_module \
- --add-module="../stream-lua-nginx-module" \
- --add-module="../stream-echo-nginx-module" \
# --without-http_echo_module \ # disable ngx_http_echo_module
# --without-http_xss_module \ # disable ngx_http_xss_module
# --without-http_coolkit_module \ # disable ngx_http_coolkit_module