summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e8c549189fa..b73fc82730ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Bo Davidson <bo.davidson@go.tarleton.edu>
# Contributor: Paul Davis <paul@dangersalad.com>
pkgname=openrgb
-pkgver=0.7
-pkgrel=6
+pkgver=0.8
+pkgrel=1
pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software."
arch=("x86_64")
url="https://gitlab.com/CalcProgrammer1/OpenRGB"
license=('GPL2')
depends=('qt5-base' 'libusb' 'hidapi' 'mbedtls')
-makedepends=('pkgconf')
+makedepends=('pkgconf' 'qt5-tools') # now need lrelease in qt5-tools for successful build >=v0.8
optdepends=('i2c-tools: Motherboard & RAM access')
# Using Link Time Optimization can cause segment fault at runtime. Disabled until upstream fix
# https://gitlab.com/CalcProgrammer1/OpenRGB/-/commit/8e6e5c1becdd610cd9206bbdcf5616ce4b43e0f1
# https://gitlab.com/CalcProgrammer1/OpenRGB/-/merge_requests/668
+
+# Expect a lot of '-pipe ignored' warnings on build if it's in makepkg.conf. This is benign.
options=('!lto')
source=(
"https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz"
openrgb.conf
openrgb.service
- https://gitlab.com/CalcProgrammer1/OpenRGB/-/commit/59732ed47e6c1392ba5236c07410dca13d4d721f.patch
)
-sha256sums=('6052e04ad736f94a91a386f6cfc0aaff9554fafdabe99cdd46a296fd49132569'
+sha256sums=('0d803753873ca1ec2bd78632b4ac605669394e7eeba2d2efe305c7f9c9d7df0c'
'b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2'
- '272dc43a77d0e48d29f32da753c7e05fd635883b173c21047f4eefa8bfc77938'
- '9d5f9435426351af7e9a12df5f75f56183585fd38729956a5cead1e2172d8e02')
+ '272dc43a77d0e48d29f32da753c7e05fd635883b173c21047f4eefa8bfc77938')
prepare() {
cd "$srcdir/OpenRGB-release_$pkgver"