summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2d05533eca0..f642a843e0a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Arsen Musayelyan <moussaelianarsen@gmail.com>
pkgname=opensend-git
-pkgver=r38.003c27d
-pkgrel=1
-pkgdesc="Send files and URLs securely across systems"
+pkgver=r39.07e35af
+pkgrel=2
+pkgdesc="Send files and securely across systems"
arch=('any')
-license=('GPLv2')
-depends=('python' 'python-pip' 'python-pynacl' 'python-zeroconf' 'python-pyftpdlib' 'python-pyqt5')
-source=('git+https://gitlab.com/moussaelianarsen/opensend.git')
+license=('Apache-2.0')
+makedepends=('go')
+source=('git+https://gitea.arsenm.dev/Arsen6331/opensend.git')
md5sums=('SKIP')
+backup=('etc/opensend.toml')
pkgver() {
- cd "$srcdir/opensend"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/opensend"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/opensend"
+ make
+}
package() {
cd "$srcdir/opensend"
- DESTDIR="$pkgdir/" SUPRESSPIP=true python3 install.py
- # Install PyAESCrypt using pip as it is not available in repos or AUR
- python3 -m pip install pyAesCrypt
+ make DESTDIR="$pkgdir" install
}