summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce565d066275..56b06c56c7a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,18 @@
pkgname=opensm
pkgver=3.3.19
-pkgrel=1
+pkgrel=2
pkgdesc='OpenFabrics Alliance InfiniBand Subnet Manager and Administrator'
arch=('x86_64' 'i686')
url=('https://www.openfabrics.org/index.php/overview.html')
license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
depends=('libibumad' 'rdma')
source=("https://www.openfabrics.org/downloads/management/${pkgname}-${pkgver}.tar.gz"
- 'opensm.service')
+ 'opensm.service'
+ 'opensm.launch')
md5sums=('b41a64985fc3050b934ce6082cbac1be'
- '130d30d701776a27ecad9c8c90b9eb09')
+ 'f1155dd8fb07ce56c427bceb7ce3fffb'
+ '7cd151f96d46ba1bc651fce0e2b7e8dc')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -35,4 +37,5 @@ package() {
# Convert from init.d to systemd
rm -rf ${pkgdir}/etc/init.d
install -Dm644 "${srcdir}/opensm.service" "${pkgdir}/etc/systemd/system/opensm.service"
+ install -Dm755 "${srcdir}/opensm.launch" "${pkgdir}/usr/bin/opensm.launch"
}