summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD86
1 files changed, 43 insertions, 43 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd6413208ff8..59e163b722ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,12 @@
-# Maintainer: lsf
-# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: lsf
# Contributor: Adam Hose <adis@blad.is>
-
pkgname=opensnitch-git
-pkgver=1.2.0.r11.a517ebe
+pkgver=1.3.0.rc.2.r19.b6cbc67
pkgrel=1
-pkgdesc="A GNU/Linux application firewall"
+pkgdesc="A GNU/Linux port of the Little Snitch application firewall"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/gustavo-iniguez-goya/opensnitch"
+url="https://github.com/evilsocket/opensnitch"
license=('GPL3')
makedepends=('git' 'go' 'python-setuptools' 'python-grpcio-tools')
depends=('libnetfilter_queue' 'libpcap' 'python-grpcio' 'python-protobuf'
@@ -17,58 +16,59 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=("etc/${pkgname%-git}d/default-config.json")
install="${pkgname%-git}.install"
-source=('git+https://github.com/gustavo-iniguez-goya/opensnitch.git')
+source=('git+https://github.com/evilsocket/opensnitch.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {
- export GOPATH="$srcdir/gopath"
- go clean -modcache
+ export GOPATH="$srcdir/gopath"
+ go clean -modcache
- cd "$srcdir/${pkgname%-git}"
- sed -i 's|local/bin|bin|g' "daemon/${pkgname%-git}d.service"
+ cd "$srcdir/${pkgname%-git}"
+ sed -i 's|local/bin|bin|g' "daemon/${pkgname%-git}d.service"
}
build() {
- cd "$srcdir/${pkgname%-git}"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external"
- pushd daemon
- make
- popd
+ cd "$srcdir/${pkgname%-git}"
+
+ pushd daemon
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external"
+ make
+ popd
- # Clean mod cache for makepkg -C
- go clean -modcache
+ # Clean mod cache for makepkg -C
+ go clean -modcache
- pushd proto
- make
- popd
+ pushd proto
+ make
+ popd
- pushd ui
- python setup.py build
- popd
+ pushd ui
+ python setup.py build
+ popd
}
package() {
- cd "$srcdir/${pkgname%-git}"
- pushd ui
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- popd
+ cd "$srcdir/${pkgname%-git}"
+ pushd ui
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ popd
- install -Dm755 "daemon/${pkgname%-git}d" -t "$pkgdir/usr/bin"
- install -Dm644 "daemon/${pkgname%-git}d.service" -t \
- "$pkgdir/usr/lib/systemd/system"
- install -dm755 "$pkgdir/etc/${pkgname%-git}d/rules"
- install -Dm644 daemon/default-config.json -t "$pkgdir/etc/${pkgname%-git}d"
- install -Dm644 daemon/system-fw.json -t "$pkgdir/etc/${pkgname%-git}d"
- install -Dm644 "debian/${pkgname%-git}.logrotate" \
- "$pkgdir/etc/logrotate.d/${pkgname%-git}"
+ install -d "$pkgdir/etc/${pkgname%-git}d/rules"
+ install -Dm755 "daemon/${pkgname%-git}d" -t "$pkgdir/usr/bin"
+ install -Dm644 "daemon/${pkgname%-git}d.service" -t \
+ "$pkgdir/usr/lib/systemd/system"
+ install -Dm644 daemon/default-config.json -t "$pkgdir/etc/${pkgname%-git}d"
+ install -Dm644 daemon/system-fw.json -t "$pkgdir/etc/${pkgname%-git}d"
+ install -Dm644 "debian/${pkgname%-git}.logrotate" \
+ "$pkgdir/etc/logrotate.d/${pkgname%-git}"
}