summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f27d8a27df73..0c82b6793bb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,16 +24,16 @@ pkgver() {
}
build() {
- cd "$pkgname"
- cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=RelWithDebInfo \
+ cmake -B build -S "${pkgname}" \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_BUILD_TYPE=RelWithDebInfo \
-D OPENSPADES_RESDIR=/usr/share/$_pkgname/Resources \
-D OPENSPADES_INSTALL_RESOURCES=share/$_pkgname/Resources \
- -D OPENSPADES_INSTALL_BINARY=bin .
- make
+ -D OPENSPADES_INSTALL_BINARY=bin
+ cmake --build build
}
package() {
- cd "$pkgname"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
rm -rf "${pkgdir}/usr/share/menu"
}