summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d093b797e107..1368df1fdc5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,10 +64,14 @@ build() {
check() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
- make tests
-
- # Connectivity tests will fail with makechrootpkg since
+ [[ -e /.arch-chroot ]] && return
+ # Connectivity tests will fail under makechrootpkg since
# it runs as nobody which has /bin/false as login shell.
+
+ [[ -e /usr/bin/scp ]] || return
+ # Tests require openssh to be already installed system-wide.
+
+ make tests
}
package() {