summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1368df1fdc5e..3f52a5871781 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,14 +64,13 @@ build() {
check() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
- [[ -e /.arch-chroot ]] && return
- # Connectivity tests will fail under makechrootpkg since
- # it runs as nobody which has /bin/false as login shell.
+ # Tests require openssh to be already installed system-wide,
+ # also connectivity tests will fail under makechrootpkg since
+ # it runs as nobody which has /bin/false as login shell.
- [[ -e /usr/bin/scp ]] || return
- # Tests require openssh to be already installed system-wide.
-
- make tests
+ if [[ -e /usr/bin/scp && ! -e /.arch-chroot ]]; then
+ make tests
+ fi
}
package() {