summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 14 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39dd7e9dc12d..11212a83ae4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,23 @@
# Maintainer: cyrant <cyrant at tuta dot io>
pkgname=opentoonz
-pkgver=1.2.1
+pkgver=1.3.0
pkgrel=1
-pkgdesc='2D animation software based on Toonz Studio Ghibli Version.'
+pkgdesc='This is software for producing a 2D animation.'
url='https://opentoonz.github.io'
license=('BSD')
arch=('x86_64')
conflicts=('opentoonz-git')
-depends=('cblas' 'freeglut' 'glew' 'libmypaint' 'qt5-multimedia' 'qt5-script' 'qt5-svg' 'sdl2' 'superlu')
+depends=('cblas' 'freeglut' 'glew' 'hicolor-icon-theme' 'libmypaint' 'qt5-multimedia' 'qt5-script' 'qt5-svg' 'sdl2' 'superlu')
makedepends=('boost' 'boost-libs' 'cmake' 'git' 'pkgconf' 'qt5-tools')
-source=(
- "git+https://github.com/opentoonz/opentoonz.git#tag=v${pkgver}"
- "${pkgname}.desktop"
- "${pkgname}.png"
-)
-md5sums=(
- 'SKIP'
- '79edaacc7ef2f7b932a2ab3e9234570e'
- '3d8620258a66ee0f58c91ea6a38e33c1'
-)
+source=("git+https://github.com/opentoonz/opentoonz.git#tag=v${pkgver}")
+md5sums=('SKIP')
build() {
- cd "${pkgname}/thirdparty/tiff-4.0.3"
+ cd "${srcdir}/${pkgname}/thirdparty/tiff-4.0.3/"
./configure --with-pic --disable-jbig && make
- cd -
-
+
+ cd "${srcdir}/"
cmake \
-H"${pkgname}/toonz/sources" \
-B"${pkgname}-build" \
@@ -33,16 +25,15 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DMYPAINT_LIB_INCLUDE_DIRS=/usr/include/libmypaint-1.3 \
-DMYPAINT_LIB_LDFLAGS=/usr/lib/libmypaint-1.3.so
- cd "${pkgname}-build"
+
+ cd "${srcdir}/${pkgname}-build/"
make
}
package() {
- cd "${pkgname}-build"
+ cd "${srcdir}/${pkgname}-build/"
make DESTDIR="${pkgdir}/" install
- cd -
-
- install -Dm644 "${pkgname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ cd "${srcdir}/${pkgname}/"
+ install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}