summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 24 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99971906cb68..b19cfc16ab48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,32 @@
pkgname=openvpn-openssl-1.0
_pkgname=openvpn
-pkgver=2.4.6
+pkgver=2.4.7
pkgrel=1
pkgdesc='An easy-to-use, robust and highly configurable VPN (Virtual Private Network) (build against openssl-1.0)'
arch=('i686' 'x86_64')
url='http://openvpn.net/index.php/open-source.html'
-depends=('openssl-1.0' 'lzo' 'iproute2' 'libsystemd' 'pkcs11-helper')
+depends=('openssl-1.0' 'lzo' 'iproute2' 'systemd-libs' 'pkcs11-helper')
conflicts=('openvpn')
provides=('openvpn')
-optdepends=('easy-rsa: easy CA and certificate handling')
-makedepends=('systemd')
+optdepends=('easy-rsa: easy CA and certificate handling'
+ 'pam: authenticate via PAM')
+makedepends=('git' 'systemd')
license=('custom')
-validpgpkeys=('F554A3687412CFFEBDEFE0A312F5F7B42F2B01E7') # OpenVPN - Security Mailing List <security@openvpn.net>
-source=("https://swupdate.openvpn.net/community/releases/openvpn-${pkgver}.tar.gz"{,.asc})
-sha256sums=('738dbd37fcf8eb9382c53628db22258c41ba9550165519d9200e8bebaef4cbe2'
- 'SKIP')
+source=("git+git://github.com/OpenVPN/openvpn.git#tag=v${pkgver}")
+sha256sums=('SKIP')
-build() {
- cd "${srcdir}"/${_pkgname}-${pkgver}
+prepare() {
+ cd "${srcdir}"/${_pkgname}
+
+ autoreconf -i
+}
- export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
+build() {
+ mkdir "${srcdir}"/build
+ cd "${srcdir}"/build
- ./configure \
+ "${srcdir}"/${_pkgname}/configure \
--prefix=/usr \
--sbindir=/usr/bin \
--enable-iproute2 \
@@ -36,13 +40,13 @@ build() {
}
check() {
- cd "${srcdir}"/${_pkgname}-${pkgver}
+ cd "${srcdir}"/build
make check
}
package() {
- cd "${srcdir}"/${_pkgname}-${pkgver}
+ cd "${srcdir}"/build
# Install openvpn
make DESTDIR="${pkgdir}" install
@@ -50,14 +54,16 @@ package() {
# Create empty configuration directories
install -d -m0750 -g 90 "${pkgdir}"/etc/openvpn/{client,server}
- # Install examples
- install -d -m0755 "${pkgdir}"/usr/share/openvpn
- cp -r sample/sample-config-files "${pkgdir}"/usr/share/openvpn/examples
-
# Install license
install -d -m0755 "${pkgdir}"/usr/share/licenses/openvpn/
ln -sf /usr/share/doc/openvpn/{COPYING,COPYRIGHT.GPL} "${pkgdir}"/usr/share/licenses/openvpn/
+ cd "${srcdir}"/${_pkgname}
+
+ # Install examples
+ install -d -m0755 "${pkgdir}"/usr/share/openvpn
+ cp -r sample/sample-config-files "${pkgdir}"/usr/share/openvpn/examples
+
# Install contrib
for FILE in $(find contrib -type f); do
case "$(file --brief --mime-type "${FILE}")" in
@@ -66,4 +72,3 @@ package() {
esac
done
}
-