summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 14 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d8660c5f293..c6b083d0bd38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,38 @@
# Maintainer: Ben Mitchell <bjosephmitchell@gmail.com>
-projectname=opman
-pkgname="$projectname-git"
-pkgver=r5.b83bef5
+_pkgname=opman
+pkgname="$_pkgname-git"
+pkgver=r8.1c0d6fc
pkgver() {
- cd "$projectname"
+ cd "$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
pkgrel=1
pkgdesc='Opinionated ArchLinux Package Manager (WIP)'
arch=('any')
-url="https://github.com/CRISPYricePC/$projectname"
+url="https://github.com/CRISPYricePC/$_pkgname"
license=('MIT')
-groups=()
-depends=()
+depends=('pacman')
makedepends=('cargo')
-optdepends=()
provides=('opman')
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("${projectname}::git+$url.git")
-noextract=()
+source=("${_pkgname}::git+$url.git")
md5sums=('SKIP')
prepare() {
+ cd $_pkgname
+
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
+ cd $_pkgname
+
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release --all-features
}
package() {
- install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$projectname"
+ cd $_pkgname
+
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$_pkgname"
} \ No newline at end of file