summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2fe4fefc071..3ed18bcdc744 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=optix
pkgver=7.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A software development kit for achieving high performance ray tracing on the GPU."
arch=('x86_64')
url="https://developer.nvidia.com/optix"
@@ -10,10 +10,14 @@ license=('custom:NVIDIA')
depends=('cuda')
options=(!strip)
_script="NVIDIA-OptiX-SDK-$pkgver-linux64.sh"
-source=("hib://$_script")
+source=("file://$_script")
sha512sums=('349baf367af7890afac87a879c8f7360cc9c93e984cf234216062af0a3cedce8fc6f3fd74240897d4b3854622ce1976a78433cbeadf6fa89c8e84d24e26eef89')
-DLAGENTS+=("hib::/usr/bin/echo %u - Please manually download $_script to $PWD from https://developer.nvidia.com/designworks/optix/download.")
+if ! [ -f $_script ]
+then
+ msg2 "Please manually download $_script to $PWD from https://developer.nvidia.com/designworks/optix/download."
+ exit 1
+fi
PKGEXT='.pkg.tar'
@@ -23,3 +27,4 @@ package() {
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
ln -s /opt/optix/doc/OptiX_EndUserLicense.pdf "$pkgdir/usr/share/licenses/$pkgname/OptiX_EndUserLicense.pdf"
}
+