summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbfb27c902f4..4aa7ac0aa51a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
_pkgname=opustags
pkgname=opustags-git
-pkgver=0.36.fcd6470
-pkgrel=2
+pkgver=0.206.4de428b
+pkgrel=1
pkgdesc="View and edit tags for opus files from the command line."
arch=('any')
-url="https://github.com/fmang/$_pkgname"
+url="https://github.com/fmang/${_pkgname}"
license=('BSD3')
depends=('libogg')
-makedepends=('git')
+makedepends=('cmake' 'git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://github.com/fmang/$_pkgname.git")
+source=("git+https://github.com/fmang/${_pkgname}.git")
md5sums=("SKIP")
pkgver()
{
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}"
echo "0.$(git rev-list --count HEAD).$(git describe --always)"
}
build()
{
-cd "$srcdir/$_pkgname"
+cd "${srcdir}/${_pkgname}"
+cmake -DCMAKE_INSTALL_PREFIX=/usr
make
}
package()
{
- cd "$srcdir/$_pkgname"
-make PREFIX=/usr DESTDIR="$pkgdir/usr" install
+ cd "${srcdir}/${_pkgname}"
+make DESTDIR="${pkgdir}" install
}
# vim:set ts=2 sw=2 et: