summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 11 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6409ebd0fb76..a150429b6ae5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
pkgname=or-tools
-pkgver=6.10
-pkgrel=2
+pkgver=7.2
+pkgrel=1
pkgdesc="Google's Operations Research tools."
arch=('x86_64')
url="https://github.com/google/or-tools"
license=('Apache')
-depends=('gcc-libs')
-makedepends=('cmake' 'git')
-source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz")
-sha256sums=('d1131ca6d7c2388400493c774dfd0b5d5c270a8a9645391876400a194354cfd6')
+depends=('gcc-libs' 'protobuf' 'gflags' 'google-glog' 'coin-or-cbc' 'protobuf')
+makedepends=('cmake' 'pkgconf' 'git')
+source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz"
+ "pkg-conf.patch")
+sha256sums=('13a4de5dba1f64e2e490394f8f63fe0a301ee55466ef65fe309ffd5100358ea8'
+ '177a5f656e6571ab60634167d47d0924e0c71c53680b620023bd9e76e36b9b82')
conflicts=('python-or-tools') # because it copies libortools.so to usr/lib
prepare() {
cd "$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/pkg-conf.patch"
cmake -H. -Bbuild \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
-DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
@@ -22,7 +25,8 @@ prepare() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DBUILD_PYTHON=OFF
+ -DBUILD_PYTHON=OFF \
+ -DBUILD_absl=ON
}
build() {
@@ -40,14 +44,4 @@ package() {
install -d -m 755 "$pkgdir/usr/share/examples"
cp -a "$pkgname-$pkgver/examples/cpp" "$pkgdir/usr/share/examples/cpp"
rm "$pkgdir"/usr/share/examples/cpp/{BUILD,CMakeLists.txt}
-
- # TODO: work with upstream to clean this (cmake is still experimental)
- cd "$pkgdir/usr/"
- rm -rf bin share/man share/pkgconfig
- rm lib/*.a
- rm lib/libz*
- rm -rf lib/pkgconfig
- rm -rf lib/cmake/{Cbc,gflags,glog,protobuf,ZLIB}
- rm -rf include/{cbc,gflags,glog,google}
- rm -rf include/{zconf,zlib}.h
}