summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17230322a99e..50a18cec8856 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: David Birks <david@tellus.space>
pkgname=oras
-pkgver=0.8.1
+pkgver=0.9.0
pkgrel=1
pkgdesc='A command line tool that allows you to push and pull files from any OCI registry'
arch=(x86_64)
url='https://github.com/deislabs/oras'
license=(MIT)
-makedepends=('go')
+makedepends=('go' 'git')
source=("$pkgname-$pkgver.tar.gz::https://github.com/deislabs/oras/archive/v$pkgver.tar.gz")
-sha512sums=('75b16c2c6fc5a27afaf44399c72f6aa654067507226ffbbfee97862dc53fb6ed944ecc1e1e790dbfe1d5d9f209d71915284b63e0beeab02864395b8385b5f004')
+sha512sums=('2bd3538eb250e41ac2ebd198cb7ca33971a63e7107808a09391ed1b67eae163d9c2f60d2aeef5dcdcd3b9f423820bc00841a5a120b6e0dce018dafadc88e0d6d')
build() {
# Flags to trim path from binary
@@ -18,7 +18,8 @@ build() {
export VERSION=$pkgver
cd $pkgname-$pkgver
- make build-linux
+ GOARCH=amd64 CGO_ENABLED=0 GOOS=linux go build -v \
+ -o bin/linux/amd64/oras github.com/deislabs/oras/cmd/oras
}
package() {