summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50a18cec8856..1f958458551d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
-# Maintainer: David Birks <david@tellus.space>
-
+# Maintainer: Xuanwo <xuanwo@archlinuxcn.org>
pkgname=oras
-pkgver=0.9.0
+pkgver=0.12.0
pkgrel=1
pkgdesc='A command line tool that allows you to push and pull files from any OCI registry'
arch=(x86_64)
url='https://github.com/deislabs/oras'
license=(MIT)
makedepends=('go' 'git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/deislabs/oras/archive/v$pkgver.tar.gz")
-sha512sums=('2bd3538eb250e41ac2ebd198cb7ca33971a63e7107808a09391ed1b67eae163d9c2f60d2aeef5dcdcd3b9f423820bc00841a5a120b6e0dce018dafadc88e0d6d')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/oras-project/oras/archive/v$pkgver.tar.gz")
+sha512sums=('589324805c38f485ecb0122e35984cd6d7b87150c2e67d36bb3ca759750b9ccc9a4803aea9c56c4cbbfb19c914fe7a077d9d091b70b54babc446ac01d3bc2091')
build() {
# Flags to trim path from binary
@@ -18,8 +17,8 @@ build() {
export VERSION=$pkgver
cd $pkgname-$pkgver
- GOARCH=amd64 CGO_ENABLED=0 GOOS=linux go build -v \
- -o bin/linux/amd64/oras github.com/deislabs/oras/cmd/oras
+ GOARCH=amd64 CGO_ENABLED=0 GOOS=linux go build \
+ -o bin/linux/amd64/oras github.com/oras-project/oras/cmd/oras
}
package() {