summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ee5f2607b5bf..b5a828261214 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Contributor: Samuel Mesa <samuelmesa@linuxmail.org>
pkgname=orfeo-toolbox
-pkgver=6.6.1
-_pkgver=6.6
+pkgver=7.0.0
+_pkgver=7.0
minorver=1
-pkgrel=1
+pkgrel=3
pkgdesc="ORFEO Toolbox (OTB) is an open source library of image processing algorithms"
arch=(x86_64 i686)
url="http://www.orfeo-toolbox.org/otb/"
license=('CeCILL')
groups=()
depends=('gdal' 'agg' 'freeglut' 'curl' 'fftw' 'tinyxml' 'muparser' 'fltk' 'python2' 'openthreads' 'boost'
- 'hdf5' 'insight-toolkit' 'libkml' 'ossim' 'libsvm' 'mapnik' 'qwt-qt4' 'opencv' 'glfw' 'openmpi')
-makedepends=('boost' 'swig' 'cmake' 'qt4')
+ 'hdf5' 'insight-toolkit' 'ossim' 'libsvm' 'mapnik' 'qwt' 'opencv' 'glfw' 'openmpi')
+makedepends=('boost' 'swig' 'cmake' 'qt5-base')
optdepends=()
provides=()
conflicts=()
@@ -27,7 +27,7 @@ source=(https://www.orfeo-toolbox.org/packages/OTB-$pkgver.tar.gz
git://github.com/jmichel-otb/GKSVM.git)
noextract=()
-md5sums=('b6733fa17e312e0f55d9cfe09607485c'
+md5sums=('314b985d112dab6d407dd6d35bccc790'
'SKIP')
@@ -36,7 +36,7 @@ _gitname="GKSVM"
prepare() {
## Module for monteverdi build
cd $srcdir/
- cp -ra $srcdir/GKSVM $srcdir/OTB-release-$_pkgver/Modules/Remote
+ cp -ra $srcdir/GKSVM $srcdir/Modules/Remote
}
build() {
@@ -51,7 +51,7 @@ build() {
cd $srcdir/build
- cmake ../OTB-release-$_pkgver \
+ cmake ../ \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_CXX_FLAGS="$CXXFLAGS -fPIC" \
-DCMAKE_C_FLAGS="$CFLAGS -fPIC" \
@@ -60,19 +60,16 @@ build() {
-DBUILD_EXAMPLES=OFF \
-DBUILD_TESTING=OFF \
-DOTB_WRAP_PYTHON=ON \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_LIBRARIES=/usr/lib/libpython2.7.so \
- -DPYTHON_INCLUDE_PATH=/usr/include/python2.7/ \
- -DOTB_INSTALL_PYTHON_DIR=/usr/lib/python2.7/site-packages/ \
-DBUILD_SHARED_LIBS=ON \
-DOTB_USE_QT=ON \
-DOTB_USE_MAPNIK=OFF \
-DOTB_USE_OPENCV=OFF \
-DOTB_USE_MUPARSER=ON \
- -DOTB_USE_LIBKML=ON \
- -DOTB_USE_LIBSVM=OFF \
- -DOTB_DATA_USE_LARGEINPUT=ON \
- -DOTB_USE_OPENMP=ON
+ -DOTB_USE_LIBKML=OFF \
+ -DOTB_USE_LIBSVM=ON \
+ -DOTB_USE_OPENMP=ON \
+ -DOTB_USE_6S=ON \
+ -DOTB_DATA_USE_LARGEINPUT=ON
make