summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e96e60b1730b..4a48ad98cdaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: William Rea <sillywilly@gmail.com>
pkgname=ortp
-pkgver=5.1.71
-pkgrel=2
+pkgver=5.2.32
+pkgrel=1
pkgdesc='A Real-time Transport Protocol (RTP) library'
arch=(x86_64)
url='https://gitlab.linphone.org/'
@@ -14,7 +14,7 @@ license=(GPL3)
depends=(bctoolbox)
makedepends=(cmake doxygen)
source=(https://gitlab.linphone.org/BC/public/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2)
-sha256sums=('40f3973162828cea964317bfcbeaa1386b564592b622f1b20dc7b99434bbfd74')
+sha256sums=('68f9fa234b56e457fa3ae7f64ff35ce614699674cf2de764a3407436d4efa33c')
prepare() {
sed '/WARN_AS_ERROR/d' -i $pkgname-$pkgver/ortp.doxygen.in
@@ -23,7 +23,9 @@ prepare() {
build() {
cmake -B build -S $pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_STATIC=OFF
+ -DENABLE_STATIC=OFF \
+ -DENABLE_DOC=NO \
+ -Wno-dev
cmake --build build
}