summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..770698f227c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Daniel Reibl <janos.daniel.reibl@pm.me>
+pkgname=osm2pgrouting
+pkgver=2.3.8
+pkgrel=1
+pkgdesc="Import tool for OpenStreetMap data to pgRouting database"
+arch=('x86_64')
+url="https://pgrouting.org"
+license=('GPL')
+
+depends=('libpqxx' 'expat')
+source=("https://github.com/pgRouting/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('6334f80ffbea0288888b864ba787252b87b5fe446a3746003d79afc125fd526460e147a230b506d35609bac8136e7ea20eb5761ce3b8dee3355d23df8a8d62e5')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -H. -Bbuild
+ cd build
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}