summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52cb7f9ee4eb..4d025e9acb0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Nicole Fontenot <nfontenot27@gmail.com>
pkgname=osu-lazer-git
-pkgver=2017.825.0_40_g2742fe46
+pkgver=2017.919.0_2_g278e51eeb
pkgrel=1
pkgdesc='Freeware rhythm video game - lazer development version'
arch=('x86_64' 'i686')
@@ -49,6 +49,11 @@ build() {
git submodule init
git submodule update --recursive
+ # HACK: OpenTK dependency that nuget can't find
+ wget \
+ -O "$HOME/.local/share/NuGet/Cache/OpenTK.3.0.0-git00009.nupkg" \
+ 'https://www.myget.org/F/opentk-develop/api/v2/package/OpenTK/3.0.0-git00009'
+
# Download dependencies
nuget restore
@@ -75,7 +80,7 @@ package() {
install -m644 "${pkgname%-git}.png" "$pkgdir/usr/share/pixmaps/${pkgname%-git}.png"
# Compiled binaries
- cd "$srcdir/osu/osu.Desktop/bin/Release"
+ cd "$srcdir/osu/osu.Game/bin/Release"
mkdir -p "$pkgdir/usr/lib/${pkgname%-git}"
for binary in *.exe *.dll; do
install -m755 "$binary" "$pkgdir/usr/lib/${pkgname%-git}/$binary"