summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 24 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa8874c3382d..9ae80c06b5c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=osvr-rendermanager-git
-pkgver=v00_06_43.r453.gdcc4f22
+pkgver=v00_06_52.r11.g03b6f9c
pkgrel=1
pkgdesc="TW, ATW and high performance rendering with OpenGL and GLES"
arch=(i686 x86_64)
@@ -29,7 +29,30 @@ prepare() {
git submodule update #--init #--recursive #NDA
mkdir -p "$srcdir/osvr-rendermanager-build"
+
+ # this copies over osvr-core files from the system into the install directory so they would simply be overwritten in /usr/lib
sed -i "/osvrrm_copy_deps(osvr::osvrClientKit osvr::osvrClient osvr::osvrCommon osvr::osvrUtil)/d" CMakeLists.txt
+
+ echo
+ echo "Patch Rendermanager to use an OpenGL Core Profile?"
+ echo "For mesa drivers you should say Y, for proprietary drivers you should say n."
+ echo "(Some of the example programs will not work with a Core Profile, this is not a rendermanagager bug, but a result of this patch)"
+ echo "For more information refer to"
+ echo "https://github.com/sensics/OSVR-RenderManager/issues/68"
+ echo "https://github.com/sensics/OSVR-RenderManager/issues/233"
+ read -p "[Y/n]? " -n 1 -r
+ echo # (optional) move to a new line
+ case "$REPLY" in
+ y*|Y*|"" )
+ echo "Patching rendermanager to use a core profile..."
+ git apply -vvv "$srcdir"/../use_core_profile_unconditionally.diff
+ echo "Patched..."
+ ;;
+ * )
+ echo "Building unpatched..."
+ ;;
+ esac
+ sleep 1
}
build() {
@@ -41,12 +64,6 @@ build() {
package() {
cd osvr-rendermanager-build
make DESTDIR="$pkgdir/" install
-
- # *sigh*
-# rm -f "$pkgdir"/usr/lib/libosvrClient.so.0.6
-# rm -f "$pkgdir"/usr/lib/libosvrClientKit.so.0.6
-# rm -f "$pkgdir"/usr/lib/libosvrCommon.so.0.6
-# rm -f "$pkgdir"/usr/lib/libosvrUtil.so.0.6
}
# vim:set ts=2 sw=2 et: