summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cda990d389ee..76a1eeba07b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: aksr <aksr at t-com dot me>
-# Contributor: Caleb Maclennan <caleb@alerque.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=otf-libertinus-git
-pkgver=6.2.r31.gefbe4ae
+pkgver=6.4.r73.g4656f77
pkgrel=1
-pkgdesc="Libertinus font family, a fork of Linux Libertine and Linux Biolinum with bugfixes and an OpenType math companion."
+pkgdesc='Libertinus font family, a fork of Linux Libertine and Linux Biolinum with bugfixes and an OpenType math companion.'
arch=('any')
-url="https://github.com/khaledhosny/libertinus"
+url='https://github.com/khaledhosny/libertinus'
license=('custom: OFL')
depends=('fontconfig' 'xorg-font-utils')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-install=otf.install
source=("$pkgname::git+https://github.com/khaledhosny/libertinus.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
find -name '*.otf' -execdir install -Dm644 {} "${pkgdir}/usr/share/fonts/OTF/{}" \;
install -Dm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
}