summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c5d28ee5085..122b9f8fa7df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Peyrille Benjamin <peyrille.benjamin@gmail.com>
# Contributor : Rogalle Quentin <quentin.rogalle@etudiant.univ-perp.fr>
pkgname=othellox
-pkgver=0_3
-pkgrel=2
+pkgver=1_0
+pkgrel=1
pkgdesc="Reversi game in C allowing AI-vs-AI automation"
arch=('any')
url="https://framagit.org/Arkhist/othellox"
@@ -10,7 +10,7 @@ license=('MIT')
depends=('ncurses')
makedepends=('clang')
source=("https://framagit.org/Arkhist/othellox/-/archive/master/othellox-master.zip")
-sha256sums=('60e6f253c581b37f57b97a25c0127abea310aa18ae0eed8181623577fe97acd8')
+sha256sums=('28c36d80975ee1337052f2b5a4f1252eb54c2939a27ef1d5628ff423887b41a1')
prepare() {
cd "${pkgname}-master"
@@ -19,7 +19,7 @@ prepare() {
build() {
cd "${pkgname}-master"
cd othellogame
- make
+ make ARCHLINUX=yes
}
check() {
@@ -35,4 +35,8 @@ package() {
install -Dm655 include/gameState.h "${pkgdir}/usr/include/othellox/gameState.h"
install -Dm655 basic-ai "${pkgdir}/usr/share/othellox/basic-ai"
install -Dm655 ordinatrice-ai "${pkgdir}/usr/share/othellox/ordinatrice-ai"
+ install -Dm655 radiation-ai "${pkgdir}/usr/share/othellox/radiation-ai"
+ install -Dm655 scanner-ai "${pkgdir}/usr/share/othellox/scanner-ai"
+ install -Dm655 xray-ai "${pkgdir}/usr/share/othellox/xray-ai"
+ install -Dm655 oracle-ai "${pkgdir}/usr/share/othellox/oracle-ai"
}